Profile image

DesignerSuite

Dev WNP78  3 months ago
4,148 downloads
Version 1.2 Tool

This mod adds two things to the designer:
- Attachment Editor to manually edit connections, disconnect or connect parts in place as well as visualise connections.
- Orthographic Camera + Blueprints to view your aircraft in plan view and compare it with plan view blueprints, to scale.

Attachment Editor

To visualise connections, enable the checkbox. When in this mode, parts connected to the selected part will be highlighted green. To be able to see hidden away connected parts easier, this mod is recommended. PC users can right click on green (connected) parts to disconnect them. Touchscreen users will have to use the "Disconnect" button and select both parts to disconnect in turn. To connect 2 parts, click "Add Connection" and follow the displayed instructions: select the first part, then the attach point on that part, then the second part, then the attach point on that part.

Orthographic

By default, the camera will switch to orthographic (flat view) mode when viewing the craft from exactly side/top/front on. This can be achieved with the "set view" buttons. It can also be enabled manually with the "force orthographic" checkbox, for an isometric effect. There are also two other checkboxes, for controlling other settings like whether to hide the platform, or hide the little attach point rectangles you get at the roots of wings (for aesthetics).

Blueprints

To add a blueprint, select the "Open Image" button and choose the path to the image. Then you can set the width or height (in metres) with the size boxes and tune it to the offset specified, as well as rotate it by the rotation input. The offset is relative to the main cockpit. You can save and load these settings using the boxes at the bottom of the window.

Android Users Only:
The built-in file browser can only access files in the game's save directory (Android/data/com.jundroo.simpleplanes) due to android's permissions or something. So when adding images, use a file browser to move them somewhere in there, perhaps into your own images folder in there.


Acknowledgements:
Thanks to SPMC for a copious amount of testing and especially Blue0Bull for waiting so long for the android version and helping weed out some bugs.

  • Log in to leave a comment
  • Profile image
    9,194 Viper3000ad

    @AtlasSP Yes the problem persists, i can add connections but locally and i can't choose any part to connect them except the most close to it. It seems the the recent version has some issues. @WNP78

    +2 25 days ago
  • Profile image
    5,163 AtlasSP

    @Viper3000ad "Add Connection" is completely inactive for me

    25 days ago
  • Profile image
    9,194 Viper3000ad

    @AtlasSP Ok if you disable it and re use it again seems to work properly.

    26 days ago
  • Profile image
    9,194 Viper3000ad

    @AtlasSP Same error here. It will help if i unistall it ? @wnpn78

    26 days ago
  • Profile image
    5,163 AtlasSP

    I have an error!
    After selecting the first point I can't click on any part of the build when using "Add Connection", even if I "Cancel" unless I have to restart "Design". But the next time it still happens, it doesn't work.
    I use DesignerSuite 1.2 and SP 1.8.305

    one month ago
  • Profile image
    975 ndfr623

    @Laurentjames123 I don't know. You can only see the images when the view is exact. It's made that way.

    +1 one month ago
  • Profile image

    Ohh wait.. I fixed it btw why doesnt it show the bleuprint when i change view (move the screen)

    one month ago
  • Profile image

    @ndfr623 I don't understand... How do we get the picture to the designer?

    one month ago
  • Profile image
    975 ndfr623

    @Laurentjames123 It does, exactly the way it does on desktop.

    To use blueprints you need to get images of the plane you're going to build. You click the left tab and click "Open Image" on a view (as the image would be from a certain view, like from the left or from the top). On Android you can only access the game's data folder, so it must be inside (Storage/Android/data/com.jundroo.SimplePlanes). I just have a diagrams subfolder and I copy-paste the downloaded images. Then, to see the image in-game, you must set the view and keep to it, which is kind of annoying as you don't have a scrollwheel on your phone and must pinch (so it's easy to get out of the view).

    one month ago
  • Profile image
    975 ndfr623

    Thanks for the new 1.2 update! I was about to complain that I couldn't add attachments with my mouse and then I saw the new update was out. I take my hat off to you!

    one month ago
  • Profile image

    Can anyone tell me if it works on android?

    one month ago
  • Profile image
    11.3k Zippy6

    @WNP78 yes you did. Much thank.

    +2 one month ago
  • Profile image
    Dev WNP78

    @Zippy6 fixed it! (I think)

    one month ago
  • Profile image
    11.3k Zippy6

    Won’t let me subscribe on steam. Says it’s hidden or I don’t have permission. Big sad.

    one month ago
  • Profile image
    3,260 Mmdben

    @jamesPLANESii @WNP78 If you clicked add connection while the painting window is open the mod simply breaks, but after restarting the game it works fine .

    +1 one month ago
  • Profile image

    I can't figure out how to use the blueprints.....

    one month ago
  • Profile image
    9,378 MintLynx

    @WNP78 Great job on the update! From what I can see all the issues with the attachment editor seem to be ironed out and it is a joy to use!

    +2 one month ago
  • Profile image

    💯

    one month ago
  • Profile image

    Oh that message I noticed it was my bad, I was naming the blueprint wrong. @WNP78

    one month ago
  • Profile image
    Dev WNP78

    @jamesPLANESii I saw your first comment, no need to send and delete to spam me with notifications (and I can still read small text, you don't need to make your entire message a title, btw). I'll try and get around to fixing it when I can, but we'll see. Shift+K still works!

    one month ago
  • Profile image
    9,378 MintLynx

    Here's another trick that might help with selecting attachment nodes! Zooming out as far as you can tends to help with selecting them. The node circles get larger, and when zoomed out enough clicking them tends to work!

    +1 one month ago
  • Profile image

    Still can’t add connections. Can’t click nodes. Plz make this your priority to fix this bug

    +3 one month ago
  • Profile image
    Dev WNP78

    @Battybatbat7 the "Show Platform" checkbox is for that

    2 months ago
  • Profile image

    I cant see the blueprint over the large grey circle. Just me being an idiot or a bug?

    2 months ago
  • Profile image
    9,378 MintLynx

    @TheXDimension32 Great!

    2 months ago
  • Log in to see more comments