Profile image

Bug thread for v1.12.128 (current version)

Dev PhilipTarpley  6 months ago

This is the place for people to report bugs/issues related to the following main updates, and subsequent hotfix updates (bringing it up to the current version of v1.12.128):

Most relevant release notes:
v1.12.123, v1.12.120/121

Next Release Timing: TBD

Notes:

  1. We won't respond to most reports, but that doesn't mean it has gone unnoticed. Every report will be seen, even if it doesn't have a direct response.
  2. It is extremely helpful to us if you could upload a simplified version of a craft which shows off the issue that you're having, as well as describing the bug in relative detail to help us track it down/fix it faster.
  3. We may remove comments which are not directly related to bugs/feedback/etc. (including our own). It isn't because they're breaking any rules, or anything. It would just be to help keep this thread more organized, which also helps us investigate the issues more efficiently.

Thanks for helping us make SimplePlanes better :)

  • Log in to leave a comment
  • Profile image
    1. Fuselage block bug
      When the length of a fuselage block is 0.04 or less (in the example post it’s 0.01) and rise and/or run is applied, the area between the two ends of the fuselage will “glow” a bright white in the designer and in the world. Personally it’s annoying at best and immersion breaking at worst. This bug has been around for a while but has never been fixed. Example

    2. Torpedo bug
      When a torpedo is launched, the propellor on the torpedo will remain perfectly upright regardless of the up or down angle of the rest of the torpedo.

    Device is an iPod Touch 7th Generation running iOS 15.6

    yesterday
  • Profile image
    1,873 Kendog84

    1)Parachute 'floor smooth/& argument' bug
    Parachute with this code causes a bug where the plane spawns below sea level and game crashes. I suspect the presence of & argument or the two arguments within the activation part + parachute quirks/bugs is what's causing the glitch.

    (activationGroup)
    floor(smooth(SelectedWeapon="R61" & ammo("R61")=0)<1,1/1))

    I tried another code with the '&' argument part as a custom variable (using clamp01), but the result was the same.

    2)Gauge 'hide option' bug
    In designer, if you set a gauge's "hide base" property to true and hide and unhide the part (with the general designer option), base shows up again (stays hidden in flight mode).

    3)Beacon light activation group bug(?)
    Neither the Beacon Light or Formation Light part accept FT for its activation group.

    Aug 5 Update

    4)Small Pylon
    Top attachment point of Small Pylon cannot be attached to a fuselage block, weapons, or another small pylon (unlike its larger counter part), and probably many other. I suspect it can't be attached to anything but wing parts.
    I find this rather inconvenient.

    Playing on iPhone (1.12.128)

    17 days ago
  • Profile image
    135 cxw0704

    Why can't the missiles fire at a low elevation?

    18 days ago
  • Profile image
    70.3k PlanariaLab

    By Ctrl+clicking on the Armed Group in the CountermeasuresDispenser, you can open the FT input screen and set the FT. However, when I go out to the map, the code I entered in that area is erased.

    18 days ago
  • Profile image
    30.6k V

    [Removed]
    It wasn't SP, Tinkercad had a stroke when importing the model

    22 days ago
  • Profile image

    Pretty simple thing I just noticed:

    When the mouse is held over the "Craft Instructions" button in the menu panel, the tooltip is the same as for the "3D Print / Export" button (Export a 3D model of your design.), instead of having its own tooltip.

    23 days ago
  • Profile image
    1,873 Kendog84

    Listing order of planes in Race Against Opponent and Dogfight mode menu seems to totally be random, and it makes it very hard to find a specific plane when you have more than a few dozen on your game, let alone a few hundred. I think it's in dire need of a comprehensible numerical+alphabetical listing order, and also a search feature (like in build mode or in-flight AI spawner) would be highly appreciated.

    +1 24 days ago
  • Profile image
    15 Mandai

    Yaw control is very bad,if turn the yaw in air,the whole thing is shaking&not turn

    25 days ago
  • Profile image
    86.9k Alisuchanka

    this is maybe not a bug report, but can you change on how we open dev console in mobile while it is enabled. currently it is using three finger tap, which makes us accidentally open it when flying, or when we tap the screen once or twice in the game's frozen state. It would be better if it can be opened via three finger swipe or an alternative way of opening dev console, like a button in the pause menu, while in the flight and/or in the designer menu, or a floating button or something.

    also, can we have a better torpedo model? the current model of the torpedo kinda doesn't look like a real one, also it is shorter than what a torpedo should be.

    +1 26 days ago
  • Profile image

    I have had problems when making planes with labels, horizontal text works just fine with curving it, but with virtical, it just goes farther into the label, this means that text will look like its hanging, please fix this bug.

    27 days ago
  • Profile image
    4,307 11qazxc

    @Kendog84

    Parts rotation bug(?)

    If i understood correctly it's gimbal lock and it isn't a bug.

    Sorry for off-topic message.

    +2 one month ago
  • Profile image
    1,873 Kendog84

    Got another one.
    FT related bug
    iOS - Perfectly good FT stops working under certain circumstances. Might be an issue specific to certain type of parts (so far experienced this with rotators and gyro).

    Haven't gotten a pin on the cause of this, but I suspect that it may have something to do with the amount and complexity of FT present in a given build. Gyro/rotators with FT that work on its own (with performance cost of the build being below 1500), when brought as a subassembly to a larger build with more stuff (higher performance cost--about 2000 to 2800), it no longer works.

    FT that stops working is something like this: "clamp01(rotator current angle)) + clamp01(Activation Group) = X." Pretty simple. Or, even something simpler like "LandingGear=1."
    I was using these to activate/deactivate rotators and gyros. 1 assembly of these, works fine (with 9 rotators and 3 gyros).
    2x this, still fine. But when I bring this assembly to a larger group of assemblies (as a unit disconnected from the cockpit, since that's crucial to what I'm trying to do) with another 18 gyros and 39 rotators (3 gyro/9 rotators per unit, and each unit has performance cost of about 380, and only one unit is connected to the primary cockpit, rest disconnected), it suddenly stops working. It only uses part variable setter, and these variables take over when the unit is saved as sub assembly.

    I'd like to submit an example of this, but the build is a WIP and I don't want to publish it yet, so this might not help much.
    I'll probably submit an example once the project is published.

    Also, I'll list some other things that might be related to this.
    -Number of aircrafts (more than 800)
    -Number of sub assemblies (more than 600)
    -Available storage space on device (8GB out of about 260gb)

    +1 one month ago
  • Profile image
    30.6k V

    Attaching a label directly to the detaching end of a detacher renders said detacher inoperable until the label is removed.
    .
    Not sure why this happens but it's been infuriating me for the past hour as I'm making cockpit directions that dissappear once they are followed

    one month ago
  • Profile image
    1,873 Kendog84

    1. Camera related bug
    When a camera or primary cockpit goes into the ocean, regardless of whether it's floating or sunk, game forcibly "Auto Orients" camera, and and skips some of the remaining cameras that are not touching the water seemingly at random.
    This does not happen when a bomb or missile with camera enabled touches and or sinks in the water. Although there is a workaround in the form of aforementioned bomb/missile camera, I still find this troublesome as it limits the utility of camera parts especially for custom missiles or bombs with camera on it.

    2. Parts rotation bug(?)
    This might be an old bug, or even a feature, but I've noticed that Y-axis Parts Rotation does not account for the current X or Z axis rotation of the part. What I mean is that whatever the X-axis rotation value, changing the Y-axis rotation value always rotates the part perpendicular to the floor of the build screen. This causes (pretty often, especially with labels) a quite annoying situation where changing either Y rotation or Z rotation doing the same thing, and you are unable to rotate the part in Y-axis perpendicular to the part itself.

    Edit
    @11qazxc mentioned that (thanks!) it's a gimbal lock and not a bug. That would explain it, but I'd still like there to be a feature where you can toggle between this mode and rotation based on part orientation. It would be great if we can have two modes for all 3 axis.

    3.Camera enabled Bomb/missile bug
    When a camera enabled bomb or missile explodes or breaks, camera doesn't get disabled, and the bomb or missile (their models) remains intact. Sorry, don't have a working example at the moment. May be more likely to happen with bomb/missile with low explosion scale?

    Forgot to mention, but these are issues I've encountered on iOS. Can't speak for other platforms.

    +1 one month ago
  • Profile image

    hey I just wanted to make you guys aware that there is a massive amount of inappropriate advertisements containing nudity on the simple planes download aircraft pages. I understand that the site needs ad revenue to stay funded but it is very disturbing to see

    one month ago
  • Profile image

    I don't know if this is a bug or not but I made a cockpit that has a lot of buttons and switches and for some reason if I add more stuff the I cannot interact with the buttons and switches this is the craft that had the problems I had to remove a few stuff for it to work in this cockpit I can still interact with the switches and buttons but if I change something I then cannot interact with it
    this version is where I cannot interact with anything except joystick and other levers, it has been tested by PlaneFlightX and he told me that he as well was not able to interact with buttons/switches except for joystick
    .
    Also my previous bug report has been solved by WIZARD2017 although I haven't tested it yet

    one month ago
  • Profile image
    1,689 OrderlyHippo

    I think I found a super annoying bug with detachers. Details in description of my unlisted post here: https://www.simpleplanes.com/a/ciC24u/4-reg-option

    one month ago
  • Profile image

    The gauge part, when hide face is set to true and you hide the part, once you clear all the hidden parts the face will show up

    +1 one month ago
  • Profile image

    My simpleplanes app keeps on showing me a black screen when I try to load into sandbox mode (build and fly)

    one month ago
  • Profile image

    Piston cannot attach, it will always disconnect when running sandbox

    +1 2 months ago
  • Profile image
    32.3k PlaneFlightX

    Let's say you have a part outputting to a variable. This part is the only source of that variable. If that part is destroyed, every single line of code using ANY variable breaks. A constant nullreferenceexception is also in the debug console.

    For example, if that type of part breaks, then I have an engine stuck at full power even if I turn off AG 1, which should stop the engine.

    2 months ago
  • Profile image
    30.6k V

    Time for a shotgun round!


    When you race against custom opponents in car races, the opponent will be disqualified apon race start
    .
    Example image


    Parachutes do not work with FT, unlike detachers which function similarly


    Bombs phase through the floor for whatever reason, so do inferno and interceptor missiles.


    The fuel tank property of a fuselage cannot be changed via overload


    Glass will break in an explosion no matter how high its health is set.


    Glass with adjacent parts broken off will not have its sides reappear, meaning that it will appear to be 100% transparent on one or both sides when a part is broken off

    +1 2 months ago
  • Profile image

    If im not wrong, if you made a new location in the USS beast, the location will be "tied" to USS Beast. But now It didn't. So it will spawn, it didn't tied with the carrier and sometimes it will be in the middle of the ocean.

    2 months ago
  • Profile image
    10.4k bosscai

    Hi Hi Hi Snowmountain ice base hole bug report: Link (ps: any rewards lmao)

    +1 2 months ago
  • Profile image
    17.9k klm747klm747

    Hello- The USS Best catapult blast shield doesn't stay down anymore for longer planes. Link to forum post

    +3 2 months ago
  • Log in to see more comments