Profile image

Bug thread for v1.12.128 (current version)

Dev PhilipTarpley  5 months ago

This is the place for people to report bugs/issues related to the following main updates, and subsequent hotfix updates (bringing it up to the current version of v1.12.128):

Most relevant release notes:
v1.12.123, v1.12.120/121

Next Release Timing: TBD

Notes:

  1. We won't respond to every report, but that doesn't mean it has gone unnoticed. Every report will be seen, even if it doesn't have a direct response.
  2. It is extremely helpful to us if you could upload a simplified version of a craft which shows off the issue that you're having, as well as describing the bug in relative detail to help us track it down/fix it faster.
  3. We may remove comments which are not directly related to bugs/feedback/etc. (including our own). It isn't because they're breaking any rules, or anything. It would just be to help keep this thread more organized, which also helps us investigate the issues more efficiently.

Thanks for helping us make SimplePlanes better :)

  • Log in to leave a comment
  • Profile image
    1,355 OrderlyHippo

    I think I found a super annoying bug with detachers. Details in description of my unlisted post here: https://www.simpleplanes.com/a/ciC24u/4-reg-option

    8 days ago
  • Profile image

    The gauge part, when hide face is set to true and you hide the part, once you clear all the hidden parts the face will show up

    13 days ago
  • Profile image

    My simpleplanes app keeps on showing me a black screen when I try to load into sandbox mode (build and fly)

    13 days ago
  • Profile image

    Piston cannot attach, it will always disconnect when running sandbox

    +1 21 days ago
  • Profile image
    30.2k PlaneFlightX

    Let's say you have a part outputting to a variable. This part is the only source of that variable. If that part is destroyed, every single line of code using ANY variable breaks. A constant nullreferenceexception is also in the debug console.

    For example, if that type of part breaks, then I have an engine stuck at full power even if I turn off AG 1, which should stop the engine.

    27 days ago
  • Profile image
    28.8k V

    Time for a shotgun round!


    When you race against custom opponents in car races, the opponent will be disqualified apon race start
    .
    Example image


    Parachutes do not work with FT, unlike detachers which function similarly


    Bombs phase through the floor for whatever reason, so do inferno and interceptor missiles.


    The fuel tank property of a fuselage cannot be changed via overload


    Glass will break in an explosion no matter how high its health is set.


    Glass with adjacent parts broken off will not have its sides reappear, meaning that it will appear to be 100% transparent on one or both sides when a part is broken off

    28 days ago
  • Profile image

    If im not wrong, if you made a new location in the USS beast, the location will be "tied" to USS Beast. But now It didn't. So it will spawn, it didn't tied with the carrier and sometimes it will be in the middle of the ocean.

    one month ago
  • Profile image
    10.3k bosscai

    Hi Hi Hi Snowmountain ice base hole bug report: Link (ps: any rewards lmao)

    one month ago
  • Profile image
    17.8k klm747klm747

    Hello- The USS Best catapult blast shield doesn't stay down anymore for longer planes. Link to forum post

    +2 one month ago
  • Profile image

    The "angle" feature for fuselage blocks does not play nice with fuselages with a non-zero "Rise" value:
    .
    When an angle is applied to a non-zero Rise value, the center around which this angle is applied, is not located at the end of the beam itself. Instead, this "center of angling" is located at the same height (in the direction perpendicular to the rear face of the fuselage) as the center of the beam. This means that when an angle is applied to a beam with a non-zero Rise, this does not only change the angle of the front face, but also affects the effective length of the beam. A visualisation (consisting of a beam with non-zero "Rise", and a turnable needle attached to a cylinder at this beams' "center of angling", showcasing how the face always aligns with this center) is present in the example craft linked below.
    .
    This behaviour is inconsistent with how angles work when the beam has a non-zero "Run". In the case of a non-zero "Run" value, the effective length (the distance to the middle of the front face, A.K.A. the front node, measured perpendicularly to the rear plane) remains unchanged. This difference is once again visualised in the example craft linked below. This behaviour for "Run" is far easier to understand / more intuitive than what happens with "Rise".
    .
    In other words: if you want to change the front face angle of a Risen part in your build, you will currently also have to change the length of the part to make sure it remains aligned with other parts in your build. This does not make any sense, since you seemingly didn't edit any parameters concerning the length.
    .
    Suggested fix:
    Change the "Angle" implementation, such that the "center of angling" always coincides with the front node, at the center of the front face.
    .
    Example Craft

    one month ago
  • Profile image
    314 Nentox888

    I have made some missiles with custom exterior and changed some values. They work fine reaching their target and exploding, but after that the touch inputs stop working completely and I have to restart the game.

    one month ago
  • Profile image

    @MrShenanigansSP
    "...I have an aircraft where if the fuselage gets damaged all moving parts such as custom cowl flaps, custom landing gear, even custom control surfaces suddenly don't work.."

    Can you give a link to the craft you're referring to and any additional info on what you're seeing/how to re-create the problem?

    -

    @Teterboro304
    "Missiles are strait up not working. On the cleaver for example, the wings will deploy but the engine just wont work."

    I'm not able to reproduce any problems with the missiles. What version are you running. Do they never work, or just under some circumstances?

    -

    @Samflugzeugpanzer
    "The torpedo physical entity the actual torpedo will aim in random directions while still maintaining original course"

    Are you talking about the torpedo propeller? If so, that is a known issue.

    -

    @PSDDHunter2012
    "The images on descreption can't show, please fix it", and "Sometimes, the other parts get auto bigger and the gear gets higher suspension and damper"

    How can I reproduce these problems to test 'em out?

    one month ago
  • Profile image

    So I think this has been a bug for a while I have an aircraft where if the fuselage gets damaged all moving parts such as custom cowl flaps, custom landing gear, even custom control surfaces suddenly don't work even if they still work they just flip 90 or 180 degrees which is kind of annoying, please fix this in a future update, I have the aircraft with the problems although it has 2,200 parts (it has 2,200 parts for a custom damage models for like bullet holes)

    one month ago
  • Profile image

    Missiles are strait up not working. On the cleaver for example, the wings will deploy but the engine just wont work.

    one month ago
  • Profile image

    It happens sometimes that when building and clicking on a part (i.e. heli engine) that all the values get set to max for no reason

    one month ago
  • Profile image

    AI aircraft may not show up or explode in the ground after spawning(Version:1.12.128)

    one month ago
  • Profile image

    The torpedo physical entity the actual torpedo will aim in random directions while still maintaining original course

    one month ago
  • Profile image
    1,784 Gooooose

    New bug:

    For some reason plane explosions are kinda op...

    Like when your plane hit the ground atleast 100 speed
    the explosion will send the cockpit 2000+ speed away
    please nerf the explosion. @PhilipTarpley

    one month ago
  • Profile image

    Thanks for reporting the issue (@Alisuchanka)

    ...and @LonelyAustrianUhlan...we're discussing the issue here

    one month ago
  • Profile image
    30.2k PlaneFlightX

    Apparently everyone should get a notification when someone follows them. I don't get such notifications.

    one month ago
  • Profile image

    @PhilipTarpley I don't know if this has been addressed before, but when I use buttons and switches in the "Once" and "Continuous" modes, the output value doesn't return to 0. Only the "Toggle" mode allows me to turn off the button

    one month ago
  • Profile image
    85.1k Alisuchanka

    I experience soft lock when I try to edit or make craft instructions. More info here

    one month ago
  • Profile image
    0 JustAI

    @DeveloperKorzalerke I'm just asking why now i know thx

    one month ago
  • Profile image

    I'm not sure how big of a deal this is, but there's actually a way to edit curated post descriptions.

    one month ago
  • Profile image

    @JustAI Bruh it's not their fault, blame google for requiring 64 bit support.

    one month ago
  • Log in to see more comments