Profile image

Add a "fire in salvos" setting for the cannon

299 Kyle123344  1.8 years ago

When I was converting my battleship from wing gun to cannon I encountered a problem. If I set the firing delay to a high number my ship cannot salvo fire. If I set the firing delay to low number I can salvo fire but my ship cannons becomes a machine gun which is very unrealistic. The fire in salvos setting will fix this: If I press the fire button all activated guns will fire all at once.

  • Log in to leave a comment
  • Profile image
    233 GOZZbro

    I want this for all the weapons as well, so not just cannons. I want to have it for bombs, missiles, cannons, and then everything all at once.

    9 months ago
  • Profile image

    Yes, I have been wanting to build a battleship but this has been my single limitation as I want to to have a more realistic and beautiful main gun set up

    1.5 years ago
  • Profile image

    Finally, a logical person! I would love this too!

    1.6 years ago
  • Profile image
    53.4k SnoWFLakE0s

    @Kimcotupan15
    .
    To avoid shell kissing set delay to smth like 0.05. I wouldn't recommend 0 sec delay anyway.

    +1 1.8 years ago
  • Profile image

    @Kimcotupan15 Good thing my phone can run a 800 part build on max settings 60fps

    +1 1.8 years ago
  • Profile image

    @Oski @SnoWFLakE0s @asteroidbook345 Thank you

    1.8 years ago
  • Profile image
    66.0k Alisuchanka

    @SnoWFLakE0s but if you're running SP in 15-20 fps, even of you put firing delay 0.0, it seems to have delay between fire.

    1.8 years ago
  • Profile image
    53.4k SnoWFLakE0s

    Yep, I already demonstrated it in one of my posts. Oski is correct, you can do it already- you just have to do it yourself.

    1.8 years ago
  • Profile image
    10.2k Xenotriver

    Or, you can set all but the first firing gun to 0 delay. They will fire at the same time, and when the cycle stops the first gun will fire after X seconds

    1.8 years ago